Table of Contents

OVERVIEW OF THIS TUTORIAL ................................................................. 3
MAP COMPOSITION IN ENVI ........................................................................ 4
Open and Display Landsat TM Data ............................................................. 4
Build the QuickMap Template ................................................................. 4
MAP ELEMENTS ..................................................................................... 6
Adding Virtual Borders ............................................................................. 6
Automatically ............................................................................................ 6
Using the Display Preferences .................................................................. 6
Using the Annotation Function ................................................................. 6
Adding Grid Lines .................................................................................... 7
Working with Annotation .......................................................................... 7
Text and Symbol Annotation ...................................................................... 8
Polygon and Shape Annotation ................................................................. 8
Line and Arrow Annotation ........................................................................ 8
Scale Bar Annotation ................................................................................ 9
Declination Diagrams ............................................................................... 9
Map Key Annotation ................................................................................ 9
Color Ramp Annotation ............................................................................ 9
Image Insets as Annotation ...................................................................... 10
Plot Insets as Annotation ......................................................................... 10
Overlaying Classification Images ........................................................... 11
Overlaying Contour Lines ......................................................................... 11
Incorporating Regions of Interest .......................................................... 11
Overlaying Vector Layers ......................................................................... 11
Overview of This Tutorial
This tutorial is designed to give you a working knowledge of ENVI’s map composition capabilities. You can use ENVI’s QuickMap utility to generate a basic map template and add more information using ENVI’s annotation capabilities. For additional information on map composition, see ENVI Help.

Files Used in This Tutorial
CD-ROM: Tutorial Data CD #1
Path: envidata/ys_tmsub

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ysratio.img (.hdr)</td>
<td>Yellowstone National Park TM Ratio Subset Image</td>
</tr>
<tr>
<td>ysratio.ann</td>
<td>Saved annotation result for above</td>
</tr>
<tr>
<td>ysratio.grd</td>
<td>Saved grid parameters for above</td>
</tr>
<tr>
<td>ys_loc.tif</td>
<td>Location image for above</td>
</tr>
</tbody>
</table>
Map Composition in ENVI

Map composition should be a simple, quick process of creating an image-based map from a remote sensing image and interactively adding key map components. In ENVI, the map composition process usually consists of basic template generation (or restoring a saved template) using the QuickMap utility, followed by interactive customization (if required) using ENVI annotation or other image overlays.

QuickMap allows you to set the map scale and the output page size and orientation; to select the image spatial subset to use for the map; and to add basic map components such as map grids, scale bars, map titles, logos, projection information, and other basic map annotation. Other custom annotation types include map keys, declination diagrams, arrows, images or plots, and additional text. Using annotation or grid line overlays means you can modify QuickMap default overlays and place all map elements in a custom manner.

You can save your map composition in a display group and restore it for future modification or printing. Using annotation, you can build and save individual templates of common map objects.

Open and Display Landsat TM Data

Before attempting to start the program, ensure that ENVI is properly installed as described in the installation guide.

1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears.

2. Navigate to envidata\ys_tmsub and select yrsratio.img. Click Open. The 5/7, 3/1, and 3/4 ratio bands are automatically loaded into the R, G, and B fields of the Available Bands List, respectively.

3. Click Load RGB. Once the image appears in a display group, complete the following steps to build a QuickMap template and to add individual map components.

Build the QuickMap Template

1. From the Display group menu bar, select File → QuickMap → New QuickMap. The QuickMap Default Layout dialog appears. This dialog allows you modify the output page size, page orientation, and map scale.

2. For this exercise, accept the default values but change the Map Scale to 200000. Click OK. A QuickMap Image Selection dialog appears.

3. Use the full image for this exercise. Click and drag the lower-right corner of the red box downward so that the whole image is selected. Click OK. The QuickMap Parameters dialog appears.

4. Click inside the Main Title field and type Yellowstone National Park Image-Map.

5. Right-click inside the Lower Left Text field and select Load Projection Info to load the image map projection information from the ENVI header.

6. For this exercise, you should leave the Scale Bars, Grid Lines, and North Arrow check boxes selected.

7. Click the Declination Diagram check box to select it.

8. Click Save Template at the bottom of the dialog. A Save QuickMap Template to File dialog appears.

9. In the Enter Output Filename field, enter yrsratio.qm. Click OK to save the QuickMap results as a QuickMap template file. You can recall this template later and use it with any image of the same pixel size by displaying the desired image and selecting File → QuickMap → from Previous Template from the Display group menu bar.

10. Click Apply in the QuickMap Parameter dialog to display the QuickMap results in a display group. If desired, you can modify the settings in the QuickMap Parameters dialog and click Apply to change the displayed QuickMap.
11. At this stage, you can output the QuickMap to a printer or a Postscript file. See “Save the Results” and “Printing” on page 14 for more information. Save or print a copy if desired. Otherwise, continue with the next step.

12. Review the QuickMap results and observe the map grids, scale bars, north arrow, and positioning of the default text.
Map Elements

ENVI offers many options for customizing your map composition. Options include virtual borders, text annotation, grid lines, contour lines, plot insets, vector overlays, and classification overlays. You can use the display group (Image window, Scroll window, or Zoom window) to perform additional, custom map composition. (If you are working in the Scroll window, you may want to enlarge it by dragging one of the corners to resize the display.) The following sections describe the different elements and provide general instructions.

Adding Virtual Borders

Default display groups contain only the image, with no surrounding blank space. Map composition typically requires some map objects to reside outside the image. ENVI provides a virtual border capability that allows annotation in the image borders without creating a new image. You can add virtual borders to an image in several ways, which are described in the following sections.

Automatically

When you generate a QuickMap, ENVI automatically adds a virtual border to all sides of the image to accommodate the QuickMap grid, and it displays a default grid.

1. To change the default border, select Overlay → Grid Lines from the Display group menu bar associated with the QuickMap. A Grid Line Parameters dialog appears.

2. From the Grid Line Parameters dialog menu bar, select Options → Set Display Borders. A Display Borders dialog appears.

3. Enter values as shown in the following figure.

4. Click OK. The new virtual border characteristics are immediately applied to the image. If you select File → Save Setup from the Grid Line Parameters dialog menu bar, the border information will be saved with the grid and will be restored when you restore the grid parameters file later.

Using the Display Preferences

You can also change virtual borders and other display settings using the Display Preferences dialog.

1. From the Display group menu bar associated with the QuickMap, select File → Preferences. A Display Parameters dialog appears with a Display Border section similar to the above figure.

2. Enter the desired values and select the desired color for the border.

3. Click OK. The new borders are immediately applied to the image.

Using the Annotation Function

You can also control virtual borders in the Annotation dialog.
1. From the Display group menu bar associated with the QuickMap, select **Overlay → Annotation**. An Annotation dialog appears.

2. From the Annotation dialog menu bar, select **Options → Set Display Borders**. A Display Borders dialog appears.

3. Enter the desired border characteristics and click **OK**. The new virtual border characteristics are immediately applied to the image. If you save an annotation to a file, the border information is also saved and restored when you restore the annotation file later.

### Adding Grid Lines

ENVI supports simultaneous pixel, map coordinate, and geographic (latitude/longitude) grids. A 100-pixel virtual border (which can be adjusted as described in “Adding Virtual Borders” on page 6) is automatically appended to the image to accommodate grid labels when grids are applied. To add or modify image grids, follow these steps:

1. From the Display group menu bar associated with the QuickMap, select **Overlay → Grid Lines**. A Grid Line Parameters dialog appears and a default grid is displayed with default grid spacings.

2. In the **Grid Spacing** field, enter **4000**.

3. To change line and label characteristics for the grid, select **Options → Edit Map Grid Attributes** or **Edit Geographic Grid Attributes** from the Grid Line Parameters dialog menu bar. Alternatively, you can access grid line parameters by clicking Additional Properties in the QuickMap Parameters dialog.

4. Click **OK** to apply the selected attributes.

5. In the Grid Line Parameters dialog, click **Apply** to post the new grid to the displayed image.

6. To save grid parameters for later use, select **File → Save Setup** from the Grid Parameters dialog menu bar and select an output file. This saves a template of the grid parameters, which you can recall later and use with another map composition (select **File → Restore Setup** from the Grid Parameters dialog menu bar).

### Working with Annotation

ENVI’s annotation utility provides a way to insert and position map objects in an ENVI display group for map composition. Several classes of map objects are available.

1. From the Display group menu bar associated with the QuickMap, select **Overlay → Annotation**. An Annotation dialog appears.

2. From the Annotation dialog menu bar, select **Object** and choose the desired annotation object.

3. In the Annotation dialog, select the **Image, Scroll, or Zoom** radio button to indicate where the annotation will appear.

4. Drag the object to a preferred location, then right-click to lock it in place.

5. To reselect and modify an existing annotation object, select **Object → Selection/Edit** from the Annotation dialog menu bar. Then select the object by drawing a box around it. You can move the selected object by clicking the associated handle and dragging the object to a new location. You can delete or duplicate an object by choosing the appropriate option from the selected menu. Right-click to relock the annotation in place.

6. Remember to select the **Off** radio button in the Annotation dialog before attempting non-annotation mouse functions in the display group.

7. Keep the Annotation dialog open for the following exercises.
Text and Symbol Annotation
ENVI currently has a wide variety of text fonts and different standard symbol sets. In addition, ENVI can use TrueType fonts installed on your system. This provides access to a wide range of different text fonts and symbols. You can interactively scale and rotate these fonts and symbols, and you can set different colors and thickness.

ENVI provides some useful symbols (including special north arrows) as a custom TrueType font. To modify the font characteristics, click Font and select ENVI Symbols in the Annotation dialog. Following are some examples of ENVI Symbols:

![Symbols Image]

Text:
1. Select Object → Text from the Annotation dialog menu bar.
2. Click Font and select a font.
3. Select the font size, color, and orientation using the appropriate buttons and fields in the Annotation dialog. For information on adding additional fonts, see “Using Other TrueType Fonts with ENVI” in ENVI Help. TrueType fonts provide more flexibility. Select one of the TrueType fonts available on your system by clicking Font, selecting a True Type option, and selecting the desired font.
4. Type your text in the empty field in the Annotation dialog.
5. Drag the text object to a preferred location in the image and right-click to lock it in place.

Symbols:
1. Select Object → Symbol from the Annotation dialog menu bar.
2. Select the desired symbol from the table of symbols that appears in the Annotation dialog.
3. Drag the text object to a preferred location in the image and right-click to lock it in place.

Polygon and Shape Annotation
You can draw rectangles, squares, ellipses, circles, and free-form polygons in an image. These can be an outline only, or filled with a solid color or a pattern. Placement is interactive, with easy rotation and scaling.

1. Select Object → Rectangle, Ellipse, or Polygon from the Annotation dialog menu bar.
2. Enter object parameters as desired in the Annotation dialog.
3. Drag the shapes to a preferred location in the image and right-click to lock them in place. For polygons, use the left mouse button to define polygon vertices and the right mouse button to close the polygon.

Line and Arrow Annotation
You can draw polylines (lines) and arrows in an image. You have full control over the color, thickness and line type, and the fill and head characteristics for arrows.

Arrows:
1. Select Object → Arrow from the Annotation dialog menu bar.
2. Enter object parameters as desired in the Annotation dialog.

3. To draw an arrow, click and hold the left mouse button and drag the cursor in the image to define the length and orientation of the arrow. Release the left mouse button to complete the arrow. You can move it by dragging the red diamond handle. Right-click to lock the arrow in place.

**Lines:**
1. Select **Object → Polyline** from the Annotation dialog menu bar.

2. Enter object parameters as desired in the Annotation dialog.

3. To draw a free-form line, click and hold the left mouse button as you are drawing. To draw a straight line, click repeatedly (without holding the left mouse button) to define the vertices. Right-click to complete the line. You can move it by dragging the red diamond handle. Right-click again to lock the line in place.

**Scale Bar Annotation**
ENVI automatically generates map scales based on the pixel size of the image in the map composition. Units include feet, miles, meters, or kilometers. You can place map scales individually, or in groups. You can configure the number of major and minor divisions, and the font and character size.

1. Select **Object → Scale Bar** from the Annotation dialog menu bar.

2. Enter object parameters as desired in the Annotation dialog.

3. Click once in the image to show the scale bar. Move it to a preferred location by dragging the red diamond handle. Right-click to lock the scale bar in place.

**Declination Diagrams**
ENVI generates declination diagrams based on your preferences. You can specify the size of the diagram and enter azimuths for true north, grid north, and magnetic north in decimal degrees.

1. Select **Object → Declination** from the Annotation dialog menu bar.

2. Enter object parameters as desired in the Annotation dialog.

3. Click once in the image to show the declination diagram. Move it to a preferred location by dragging the red diamond handle. Right-click to lock the diagram.

**Map Key Annotation**
Map keys are automatically generated for classification images and vector layers, but you can manually add them for all other images. Following is an example of a map key:

1. Select **Object → Map Key** from the Annotation dialog menu bar.

2. Click **Edit Map Key Items** to add, delete, or modify individual map key items.
3. Click once in the image to show the map key. Move it to a preferred location by dragging the red diamond handle. Right-click to lock the map key in place.

4. If you want a border and title for the map key, you must add these separately as polygon and text annotations, respectively:

Color Ramp Annotation
You can create gray scale ramps and color bars for gray scale and color-coded images, respectively. This option is not available with RGB images.

1. Select Object → Color Ramp from the Annotation dialog menu bar.
2. In the Annotation dialog, enter minimum and maximum values and intervals as desired. Also set vertical or horizontal orientation.
3. Click once in the image to show the color ramp. Move it to a preferred location by dragging the red diamond handle. Right-click to lock the color ramp in place.

Image Insets as Annotation
While mosaicking provides one way to inset an image into another, you can also inset images while composing and annotating maps.

1. Ensure that the image to be inset is listed in the Available Bands List.
2. Select Object → Image from the Annotation dialog menu bar.
3. Click Select New Image. An Annotation Image Input Bands dialog appears.
4. Select the image from the Available Bands List in the Annotation Image Input Bands dialog and perform optional spatial subsetting. Click OK.
5. Click once in the image to show the inset. Drag the green diamond handle to resize the inset as desired. Right-click to lock the inset in place.

Because 8-bit displays cannot easily assign a new color table to the inset image, ENVI only shows a gray scale image in the display group. If your display has 24-bit color, a color image will be displayed.

Plot Insets as Annotation
You can easily inset ENVI plots into an image during the map composition/annotation process. These vector plots maintain their vector character (meaning they will not be rasterized) when output to the printer or to a Postscript file. They will not appear when output to an image.

1. You must have a plot window open, such as an X Profile, Y Profile, Z Profile, spectral plot, or arbitrary profile.
2. Select Object → Plot from the Annotation dialog menu bar.
3. Click Select New Plot. A Select Plot Window dialog appears.
4. Select the plot and enter the desired dimensions to set the plot size. Click **OK**.

5. Click once in the image to show the plot. Right-click to lock the plot in place.

Because 8-bit displays cannot easily assign a new color table to the inset plot, ENVI only shows a representation of the plot in the display group. The actual plot is placed when the image is output directly to the printer or to a Postscript file, and the annotation is burned in. Again, this option does not produce a vector plot when output to “Image.”

**Overlaying Classification Images**

ENVI classification images can be used as overlays during map composition. First, classify the image (see ENVI Help for procedures) or open an existing ENVI classification image. Once the classified image is listed in the Available Bands List, then you can use it as an overlay.

1. From the Display group menu bar associated with the map composition, select **Overlay → Classification**. A file selection dialog appears.

2. Select an ENVI classification image and click **OK**. An Interactive Class Tool dialog appears.

3. Turn on specific classes to appear in the map composition by selecting the corresponding **On** check boxes. The selected classes will appear in the appropriate color as an overlay on the image.

4. You can change class colors and names by selecting **Options → Edit class colors/ names** from the Interactive Class Tool dialog menu bar.

**Overlaying Contour Lines**

You can contour Z values of images and overlay the contour lines as vectors on an image background. Digital elevation models (DEMs) work best. Add contours to a map composition as follows:

1. From the Display group menu bar associated with the map composition, select **Overlay → Contour Lines**. A Contour Band Choice dialog appears.

2. Select the desired image to contour and click **OK**. A Contour Plot dialog appears.

3. To use the default contour values, click **Apply**. Otherwise, you can add new contour levels, edit contours, and change colors and line types using the Contour Plot dialog. See ENVI Help for details.

**Incorporating Regions of Interest**

You can incorporate Regions of interest (ROIs) into ENVI map compositions. Generate ROIs by drawing them, by thresholding specific image bands, by utilizing 2D or n-D scatter plots, or by performing vector-to-raster conversions. See ENVI Help for details. Display an ROI in a map composition as follows:

1. From the Display group menu bar associated with the map composition, select **Overlay → Region of Interest**. An ROI Tool dialog appears, listing any existing ROIs having the same dimensions as the displayed image. These ROIs appear in the image.

2. Add or modify ROIs as desired. See ENVI Help for further details.

**Overlaying Vector Layers**

ENVI can import shapefiles, MapInfo files, Microstation DGN files, DXF files, ArcInfo interchange files, USGS DLG files, or ENVI vector files (.evf).
1. From the Display group menu bar associated with the map composition, select **Overlay → Vectors**. A Vector Parameters dialog appears.

2. From the Vector Parameters dialog menu bar, select **File → Open Vector File**. A file selection dialog appears.

3. Select a file and click **Open**. An Import Vector Files Parameters dialog appears.

4. Select the appropriate map projection, datum, and units for the vector layer.

5. Click **OK**. ENVI converts the input vectors into an ENVI vector format (.evf).

6. Load the vectors into the map composition by clicking **Apply** in the Vector Parameters dialog.

7. In the Vector Parameters dialog, adjust the vector attributes to obtain the desired colors, thickness, and line types. See the **Vector Overlay and GIS Analysis** tutorial or see ENVI Help for additional information.
Customize the Map Layout

This section uses several map elements described in the previous sections to demonstrate some of ENVI’s custom map composition capabilities.

The QuickMap you created earlier (see pages 2-4) will be used in the following exercises. If you already closed ysratio.img, redisplay it as follows.

1. From the ENVI main menu bar, select File → Open Image File. A file selection dialog appears.

2. Navigate to envidata\ys_tmsub and select ysratio.img. Click Open. The 5/7, 3/1, and 3/4 ratio bands are automatically loaded into the R, G, and B fields of the Available Bands List, respectively.

3. Click Load RGB.

Load the QuickMap Template

Once the image is displayed, follow these steps to load the previously saved QuickMap template and to add individual map components:

1. From the Display group menu bar, select File → QuickMap → from Previous Template. The Enter QuickMapTemplate Filename dialog appears.

2. Navigate to your output directory, select ysratio.qm, and click Open. A QuickMap Parameters dialog appears.

3. Click Apply to generate the QuickMap image. The Load To: Current Display button is selected by default, so the QuickMap parameters are applied to the display group from which you started QuickMap.

4. Restore saved grid parameters by selecting Overlay → Grid Lines from the Display group menu bar associated with the QuickMap. A Grid Line Parameters dialog appears.

5. From the Grid Line Parameters dialog menu bar, select File → Restore Setup. A file selection dialog appears.

6. Navigate to envidata\ys_tmsub and select the saved grid parameters file ysratio.grd. Click Open, followed by Apply.

7. Modify some of the grid line parameters and click Apply to show your changes on the image. Be sure to save any changes by selecting File → Save Setup from the Grid Line Parameters dialog menu bar.

8. Restore saved ENVI annotation by selecting Overlay → Annotation from the Display group menu bar associated with the QuickMap. The Annotation dialog appears.

9. Select File → Restore Annotation from the Annotation dialog menu bar.

10. Navigate to envidata\ys_tmsub and select the saved annotation file ysratio.ann. Click Open.

11. In the Annotation dialog, click the Image radio button, select Object → Selection/Edit from the menu bar, and click and drag a box around the annotation objects in the QuickMap image window. A red diamond handle appears for the selected objects.

12. Click and drag the handles to move the annotation objects. Modify some parameters for the selected objects. Right-click the objects to lock them in place. Be sure to save any changes by selecting File → Save Annotation from the Annotation dialog menu bar. See ENVI Help for further details.
Save the Results
You can save a map composition for future modification as a display group, or with the map composition “burned in” to an image.

Saving for Future Modification
This is the most flexible option.

1. From the Display group menu bar associated with the map composition, select **File → Save as Display Group**.
2. Enter an output filename and click **OK**.
3. To restore this map composition, select **File → Restore Display Group** from the ENVI main menu bar.

Saving as a “Burned-in” Image

1. From the Display group menu bar associated with the map composition, select **File → Save Image As → Postscript File**. An ENVI QuickMap Print Option dialog appears.
   - Select **Standard Printing** and click **OK** to output a Postscript file. An Output Display to Postscript File dialog appears. Change the page size and scaling parameters as desired. This option provides additional control, but it may produce a map that does not fit well with the originally selected QuickMap scale.
   - Select **Output QuickMap to Postscript**, select an output filename, and click **OK** to output a Postscript file with the specified QuickMap page size and scaling. If your additional annotation enlarged the image so it will not fit in the specified page size, ENVI asks if you want to output to multiple pages. If so, click **Yes**, and ENVI automatically creates multiple Postscript files.

Saving as an Image File
You can save your map composition as an image file. Output formats include ENVI (binary) image, BMP, HDF, JPEG, PICT, PNG, SRF, TIFF/GeoTIFF, and XWD, as well as common image processing system formats such as ERDAS (.lan), ERMAPPER, PCI, and ArcView Raster.

1. From the Display group menu bar associated with the map composition, select **File → Save Image As → Image File**.
2. Set the resolution, output file type, and other parameters as described in ENVI Help; enter an output filename; and click **OK**.

Printing
You can also select direct printing of the ENVI map composition, in which case, the map composition will be printed directly to your printer using system software drivers.

1. From the Display group menu bar associated with the map composition, select **File → Print**. An ENVI QuickMap Print Preferences dialog appears.
2. Select **Standard Printing** or **Output QuickMap to Printer** as described above.
3. Choose your printer, then click **OK**.

In all of the output options listed above, graphics and map composition objects are burned into the image on output. The following figure shows an example of a final map composition produced in ENVI using QuickMap and custom map composition.